Protect your corporate IT network from hackers and other unwanted intruders with Proxy Sentinel™. Click here for all the details and get the peace of mind you deserve.
Back to our Homepage Proxy Sentinel™ high performance Internet proxy server and secure firewall solution Firewall Sentinel™ secure & powerful Internet firewall solution About Internet Security.ca and GCIS Frequently Asked Questions on Internet security issues Internet Security Industry News - Stay informed of what's happening Contact Internet Security.ca today and order your Proxy Sentinel™ or Firewall Sentinel™ server now!

VMware urges vCenter and ESXi users to install its latest security patches

If you need reliability when it comes to SMTP servers, get the best, get Port 587.

Get a powerful Linux Dual-Core dedicated server for less than $2.67 a day!

Share on Twitter.

October 2, 2015

Click here to order the best deal on a HP enterprise dedicated server and at a great price.

VMware said earlier this morning that it's urging the users of its vCenter Server and ESXi vSphere software to install its latest patches to fix security critical vulnerabilities that can allow remote-code execution and denial of service on its platform.

The vCenter security flaw was first reported by Doug McLeod of the security firm 7 Elements towards the beginning of the year, and the researchers have been working with VMware to come up with a fix ahead of Thursday's public disclosure.

The security vulnerability, which affects vCenter Server versions 5.0 through 6.0 on all supported platforms, involves an improperly configured Java Management Extensions (JMX) service that can be manipulated remotely without authentication.

"The JMX service allows users to call the 'javax.management.loading.MLet' function, which permits the loading of an MBean (managed Java bean) from a remote URL," 7 Elements explained.

"A potential attacker can set up their remote Web Service to host an MLet text file that points to a malicious JAR file," McLeod added.

7 Elements has published proof-of-concept code that takes advantage of the bug and says there are already at least two Metasploit modules and a standalone exploit for it.

A second bug in vCenter (this one spotted by researchers at Google) can allow an attacker to create a denial-of-service condition by sending the server a maliciously crafted message.

Along with the vCenter fixes, VMware has also identified and patched a security vulnerability in its ESXi hypervisor software involving the OpenSLP service location protocol service.

An attacker who exploits a memory management error in the software can potentially execute code on the ESXi host remotely, nevertheless.

This second security bug, which was spotted by researcher Qinghao Tang of Chinese security firm Qihoo 360, affects ESXi versions 5.0, 5.1, and 5.5. However, version 6.0 is not affected, we are told.

Security patches for all of the above mentioned flaws are available today. Information on which patches are appropriate for which versions of ESXi and vCenter is available from VMware's security advisory.

But you need to watch out for patching to ESXi 5.5 Update 3: this has a nasty bug that crashes guest virtual machines if you delete a snapshot.

Source: VMware.

Get a powerful Linux Dual-Core dedicated server for less than $2.67 a day!

Share on Twitter.


Home | Proxy Sentinel™ | Firewall Sentinel™ | FAQ | News | Sitemap | Contact
Copyright © Internet Security.ca    Terms of use    Privacy agreement    Legal disclaimer